2019 check engine & trac off

Discussion in 'Maintenance' started by wolfbear, Apr 21, 2019.

  1. wolfbear

    wolfbear Member

    Bought a 2019 Tacoma in December. 3700 miles now.
    •Check engine/trac off light came on.
    •Dealership said a stored code, no explanation why, they just reset it 4/15/19 kept vehicle all day
    IMG_1965.jpg
    •happened again, dropped vehicle off Wednesday night 4/17/19 and picked up Friday 4/19/19, said to be fixed.
    IMG_1966.jpg
    •And now yesterday 4/21/19
    IMG_1953.jpg

    WTH?
     
    OR17TRD and B-Man like this.
  2. Avatar

    Tacoma Forum Sign Up!

    Join TacomaForum.com Today - It's Totally Free!

    Are you a Toyota truck fan? If so we invite you to join TacomaForum.com. Our site is specifically designed for you and it's a great place for Toyota Tacoma Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Toyota Tacoma fans. Whether your an old timer or just bought your Tacoma you'll find that TacomaForum.com is a great community to join. Best of all it's totally free!

    Join TacomaForum.com Today! JOIN FOR FREE

  3. Joisey

    Joisey Well-Known Member

    Time to file a complaint with Toyota. Obviously the dealer has no idea what they are doing.
     
    B-Man likes this.
  4. whippersnapper02

    whippersnapper02 Negative Nancy

    Trac off will always come on with the CEL. The new engines had CPS issues from the get go.
     
  5. OP
    wolfbear

    wolfbear Member

    Only my 4th vehicle ever (I’m over 50), and only the 2nd ever bought brand new. Never had issues with the other (01 Xterra).
    So, filing a complaint with Toyota is a should do?

    Dealership had vehicle for 3 days, and didn’t drive today because of the issue.
     
  6. Joisey

    Joisey Well-Known Member

    I would file a complaint with Toyota. Best to have this in file in the event it turns out to be a recall or some such.
     
    black2019tacoma, n7narcosis and B-Man like this.
  7. rcustoms

    rcustoms Member

    Any answer on this ? My 2012 just got that this morning?
     
  8. OP
    wolfbear

    wolfbear Member

    I’ll let you know this evening
     
  9. whippersnapper02

    whippersnapper02 Negative Nancy

    The same code for the CPS or just a check engine light in general?
     
  10. OP
    wolfbear

    wolfbear Member

    It’s still at dealership, dropped it off 4-22-19.
    I have started a claim using the SC lemon law.
     
    OR17TRD and whippersnapper02 like this.
  11. bdarnold12

    bdarnold12 Well-Known Member

    If it comes on again run by youre local parts store and have them see what code its showing. They don't charge you anything to read the codes and it will give you an idea what youre looking at. Could be something so simple that they can't find it.
     
    black2019tacoma and B-Man like this.
  12. OP
    wolfbear

    wolfbear Member

    Just talked to the dealership and was told they would it ready tomorrow (4-30-19)

    Something about the camshaft and it’s the first time the shop has done this particular repair.
     
    OR17TRD likes this.
  13. rcustoms

    rcustoms Member

    On my 2012 it has something to do with the air injection or air valves is what my codes said
     
    glynch23 likes this.
  14. bdarnold12

    bdarnold12 Well-Known Member

    Google you're code and it will give you a list of things to check before you start changing parts. A lot of people think the code readers will tell you what needs changed, what they tell you is what system is throwing the code, then its up to you to trouble shoot that system and figure out whats wrong.
     
    Bogunn likes this.
  15. OR17TRD

    OR17TRD Well-Known Member

    B.C. and B-Man like this.
  16. Moose Meat

    Moose Meat New Member

    My 2019 Tacoma with 5k miles just had the same problem. When I brought the truck into the dealer for regular 6 month maintenance they called and asked if I had noticed the check engine light was on. I had not. The guy said when the tech got into the car to move it to the bay the light was on and the engine sputtered. Fast forward 4 days later I drive the truck maybe 10 miles, park it, get back in and notice it's running rough, Trac off and check engine lights were on. I barely got out of the parking lot, fastest I could go was maybe 5mph. Toyota roadside service guy asked if I wanted to un-plug battery and reset the codes. Nope, I'm not gonna get stuck again. So now it sits at the dealer and I hope like hell this isn't a lemon but I'm gonna keep track of everything. I have yet to see any definitive fix to this problem.
     
    tooter and B.C. like this.

Share This Page