Engine misfire

Discussion in '2005 - 2015 Toyota Tacoma' started by Mel Bjork, May 12, 2022.

  1. Mel Bjork

    Mel Bjork Member

    2008 tacoma 255,000 miles 4 cylinder, I got a PO301 code (#1 Cyl. misfire) I changed all four plugs and #1 ignition coil and all worked great for about 40 miles and then the same code came back. Not sure what my next step should be?

    #1 cyl. compression is 140

    I've been doing some research and I think I should replace the injectors. Has anyone used rebuilt injectors? I'm looking at them on Rockauto.
     
    Last edited: May 12, 2022
  2. Avatar

    Tacoma Forum Sign Up!

    Join TacomaForum.com Today - It's Totally Free!

    Are you a Toyota truck fan? If so we invite you to join TacomaForum.com. Our site is specifically designed for you and it's a great place for Toyota Tacoma Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Toyota Tacoma fans. Whether your an old timer or just bought your Tacoma you'll find that TacomaForum.com is a great community to join. Best of all it's totally free!

    Join TacomaForum.com Today! JOIN FOR FREE

  3. TacoTruck2019

    TacoTruck2019 Well-Known Member

    I'd try running some injector cleaner in you're gas first. As far as changing injectors I'd only use Toyota OEM injectors.
     
    B-Man likes this.
  4. OP
    Mel Bjork

    Mel Bjork Member

    I just installed new injectors and ignition coils and it's still missing?
     

Share This Page