2014 tacoma

Discussion in '2005 - 2015 Toyota Tacoma' started by constantine, Feb 18, 2018.

  1. constantine

    constantine Member

    Squeaky suspension. Need help, can’t locate the noise. Squeaking don’t stop...getting in/out the truck, while driving, lil’ shake...etc.
     
    Last edited: Feb 18, 2018
  2. Avatar

    Tacoma Forum Sign Up!

    Join TacomaForum.com Today - It's Totally Free!

    Are you a Toyota truck fan? If so we invite you to join TacomaForum.com. Our site is specifically designed for you and it's a great place for Toyota Tacoma Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Toyota Tacoma fans. Whether your an old timer or just bought your Tacoma you'll find that TacomaForum.com is a great community to join. Best of all it's totally free!

    Join TacomaForum.com Today! JOIN FOR FREE

  3. OR17TRD

    OR17TRD Well-Known Member

    Coils? Front shocks? Rear leafs? All of it? Can’t help without knowing where it’s coming from. If you can post video of it squeaking and where it’s coming from we could give you some things to try.
     
  4. OP
    constantine

    constantine Member

    It’s when the truck is push down. I can hear the noise around the front shocks
     
  5. OP
    constantine

    constantine Member

    I’m new to the forum, can we post video here, if yes how?
     
  6. kp.taco

    kp.taco Well-Known Member

    "It’s when the truck is push down"
     
  7. Bogunn

    Bogunn Well-Known Member

    Push down? Like over bumps and stuff? Or under a load?
     
    kp.taco likes this.
  8. OR17TRD

    OR17TRD Well-Known Member

    Best way is to upload the video to YouTube and post the link for it.
     
    Bogunn likes this.
  9. OP
    constantine

    constantine Member

    Just by getting inside the truck
     
  10. OP
    constantine

    constantine Member

    Not even a load, even my 5yrs old son shake the car it squeak
     
  11. drtyota09

    drtyota09 Member

    I’d start by pressure washing all of your suspension. Tends to work on mine I think some dirt and stuff gets stuck inside where you don’t want it Once it dries I use some heavy duty silicone spray because it’s clear and dries so stuff doesn’t stick to it. Any lube will work tho make sure to spray the leaf springs well
     
    OR17TRD and Bogunn like this.
  12. OP
    constantine

    constantine Member

    Ok will try that thanks, if it doesn’t work I’ll upload video on youtube
     
  13. TacoKen

    TacoKen Well-Known Member

    I'm fighting the same thing with my 2015 4X4, but only seems to squeak while off-roading.
     
  14. OP
    constantine

    constantine Member

    No luck I sprayed the bushing, still squeak. But haven’t try the sway bar rubber bushing
     
  15. TacoKen

    TacoKen Well-Known Member

    I also sprayed the rear leaf areas and didn't do anything. BUT, after driving it more it sounds like it's coming from the front and not the rear. Going to spray WD40 on the front sway bar bushes and see if that helps.
     
  16. TacoKen

    TacoKen Well-Known Member

    Went under the front end and tightened all the nuts/bolts to spec. Sprayed the sway bar bushes with WD40. Still squeaking and seems to be getting worse each day I drive it. Think it's time to take it to a local off-road shop to check it out. Really embarrassing to drive around with the squeaking. I have the Toytec Boss kit and emailed them to see if they have any info but NO response from them. Guess once they sell something they are done.
     
  17. whippersnapper02

    whippersnapper02 Negative Nancy

    Sway bar bushings need grease.

    The only thing I can think of is the control arm bushings. There's no grease fittings for them though.
     
  18. TacoKen

    TacoKen Well-Known Member

    I'll drop the sway bar and grease the bushes. Thanks
     
  19. vwgtiturbo

    vwgtiturbo Well-Known Member

    I'll go with it needing new pads in the leaf springs. After doing this, my '05 stopped.

    Edit: just saw the other replies, disregard.
     
    OR17TRD likes this.
  20. TacoKen

    TacoKen Well-Known Member

    Hoping the sway bar bushes are rubber and not poly. If poly they are hard to remove and install. Not sure the type of grease but will make a trip to Napa and see what they have. Drives me crazy with all the squeaking. Seems to get worse the more they warm up. With only about 18K miles on the truck they shouldn't be squeaking like that.
     
    vwgtiturbo likes this.
  21. vwgtiturbo

    vwgtiturbo Well-Known Member

    Keep us in the loop! Good learning experience for those of us that haven't (yet) experienced it.
     

Share This Page