Bad U joint ?

Discussion in '2005 - 2015 Toyota Tacoma' started by 7_PUNSHR, Jan 13, 2019.

  1. 7_PUNSHR

    7_PUNSHR Well-Known Member

    Really bad squeezing when I’m on the gas from the rear
     
    texasred likes this.
  2. Avatar

    Tacoma Forum Sign Up!

    Join TacomaForum.com Today - It's Totally Free!

    Are you a Toyota truck fan? If so we invite you to join TacomaForum.com. Our site is specifically designed for you and it's a great place for Toyota Tacoma Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Toyota Tacoma fans. Whether your an old timer or just bought your Tacoma you'll find that TacomaForum.com is a great community to join. Best of all it's totally free!

    Join TacomaForum.com Today! JOIN FOR FREE

  3. kp.taco

    kp.taco Well-Known Member

    Squeezing?
     
    texasred and B-Man like this.
  4. Crawdad

    Crawdad Well-Known Member

    Wait, who squeezes your rear everytime you fart?

    I've had a couple of U-joints go out, usually starts out as a 'chirp chirp chirp' with extra load, like going up a long hill or pulling a trailer...
     
    7_PUNSHR, texasred, Bojangles and 2 others like this.
  5. OP
    7_PUNSHR

    7_PUNSHR Well-Known Member

    Squeaking .
     
    B-Man, kp.taco and texasred like this.
  6. texasred

    texasred Well-Known Member

    Dry shocks or loose spring clips?
     
    Last edited: Jan 14, 2019
    B-Man likes this.
  7. OP
    7_PUNSHR

    7_PUNSHR Well-Known Member

    It did end up being my u joint. Replaced all three. What caused them to go out was my center mount bearing.
     
    B-Man, texasred and Crawdad like this.
  8. TacoKen

    TacoKen Well-Known Member

    Carrier bearing?
     
    B-Man and texasred like this.

Share This Page