Chassis Grounding... Yes no???

Discussion in '2005 - 2015 Toyota Tacoma' started by Tacoma06, May 13, 2018.

  1. Tacoma06

    Tacoma06 Well-Known Member

    So. I have dual Battery National Luna smart solenoid System. I recently removed my ground to chassis as requested by National Luna and Blue Sea Fuse Block Tech. Now everyone 7 days. I have a check engine light show up and I can get rid of it by taking power away from truck for 10 seconds and gone.

    Any ideas or options on why grounding to the Chassis is done by Factory but not recommended by any aftermarket companies?

    truck seems to run fine with it without the grounding wire to Chassis. I plan to leave off. Until I know more I guess. IMG_1167.jpg
     
  2. Avatar

    Tacoma Forum Sign Up!

    Join TacomaForum.com Today - It's Totally Free!

    Are you a Toyota truck fan? If so we invite you to join TacomaForum.com. Our site is specifically designed for you and it's a great place for Toyota Tacoma Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Toyota Tacoma fans. Whether your an old timer or just bought your Tacoma you'll find that TacomaForum.com is a great community to join. Best of all it's totally free!

    Join TacomaForum.com Today! JOIN FOR FREE

  3. OP
    Tacoma06

    Tacoma06 Well-Known Member

    Truck still running good. Hmm.
     
  4. OP
    Tacoma06

    Tacoma06 Well-Known Member

    Seems to me it’s an extra wire ahahahhaha.
     

Share This Page